ARTIFACTORY: How to resolve 'the build info URL generated by Jenkins Pipeline giving 404 Not Found
In this article, we will be resolving the “404 Not Found error” which you may encounter in some cases while navigating to build info with the URL generated by Jenkins while publishing a build.
The URL generated by Jenkins navigates us to the build info in Artifactory and it gives us the 404. Below are the example screenshots of the URL generated in the Jenkins pipeline and the Artifactory UI giving a 404 error:
As we can see the above URL generated has the below incorrect format:-
https://<ART-URL>/artifactory/ui/builds/
Generally, the above issue occurs when the Platform URL of JFrog in Jenkins Configuration has not been set correctly.
In order to overcome the 404 error, the /artifactory context should be removed from the Jenkins Configuration Page for the JFrog Platform.
Follow the below steps to configure the JFrog Platform with Jenkins.
2. Under JFrog, Check the JFrog instance details, here you may see that /artifactory is appended with the base URL. Below is the screenshot.
3. If that is the case, remove the /artifactory context from the JFrog instance details and click on Test connection and click on Apply and Save the configuration.
4. Then, run the Jenkins job again and we will see that this time the URL generated does not have /artifactory in it. Refer to the below screenshot.
Great, the 404 error should not occur anymore.