ARTIFACTORY: How to resolve the error “org.yaml.snakeyaml.scanner.ScannerException” in association with the hint “Do not use \tCTAB) for indentation”

AuthorFullName__c
Shivani Budhodi
articleNumber
000006078
FirstPublishedDate
2024-04-21T15:20:54Z
lastModifiedDate
2025-07-22

ARTIFACTORY: How to resolve the error “org.yaml.snakeyaml.scanner.ScannerException” in association with the hint “Do not use \tCTAB) for indentation”


This article describes the remediation steps to resolve the following error, which is often noticed at the time of service initialization.

Caused by: org.jfrog.common.JsonSensitiveDataException: while scanning for the next token found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)
 in 'reader', line 11, column 1:
    	driver: com.mysql.jdbc.Driver
    ^

	at com.jfrog.sysconf.SysYamlSource.load(SysYamlSource.java:93)
	at com.jfrog.sysconf.SysYamlSource.<init>(SysYamlSource.java:65)
	... 28 common frames omitted
Caused by: org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token
found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)
 in 'reader', line 11, column 1:
    	driver: com.mysql.jdbc.Driver

Root Cause: 

The aforementioned exception will be returned in the logs if the Artifactory service fails to parse the YAML file during the service initialization, especially if the service identified the indentation to be having an issue. As the message clearly states not to use TAB for indentation, it is evident that the file’s indentation has been done using the TAB key instead of actual spaces.

Remediation Step: 

It is required to evaluate the system.yaml file present under the $ARTIFACTORY_HOME/var/etc/ for any TABs added instead of spaces. The actual indentation of the system.yaml file can be referred from the JFrog Wiki here .

The validation of the YAML file (system.yaml) can be done through the validators available in IDEs or any other validation tools supported at your organization level.


Note: Restart is required for the changes to take effect in the Artifactory system.yaml file. Once you’ve corrected the misconfiguration, consider performing a restart of the Artifactory instance.