ARTIFACTORY: LDAP - Unwilling to perform during LDB_SEARCH

AuthorFullName__c
Yuvarajan Johnpaul
articleNumber
000005329
FirstPublishedDate
2022-07-13T11:00:10Z
lastModifiedDate
2022-07-13

ARTIFACTORY: LDAP - Unwilling to perform during LDB_SEARCH

Symptoms:

– When searching Groups by the user in 'Edit LDAP Group Settings', the server would return the following error if the list of groups is more than 999.

LDAP: error code 53 - error in module paged_results: Unwilling to perform during LDB_SEARCH (53)]; nested exception is javax.naming.OperationNotSupportedException: [LDAP: error code 53 - error in module paged_results: Unwilling to perform during LDB_SEARCH (53)]; remaining name 'CN=Users,DC=grease,DC=saabgroup,DC=test'

What does this error mean?

This error indicates an issue whereby the LDAP server doesn't support PagedResultControl.  

Case-1:

To overcome this issue, it is required to add the property
artifactory.ldap.paging.support=false
into the
/opt/jfrog/artifactory/var/etc/artifactory/artifactory.system.properties file. This amendment needs a restart of the Artifactory instance.

Case-2:

Let’s say the above workaround doesn’t help as the remote LDAP servers are already supporting the PagedResultControl like OpenLDAP, and IBM the issue can be resolved by enabling the Paged Results setting available through the Artifactory UI.

User-added image

In this case, the parameter described in case-1 is not required to be added.