ARTIFACTORY: When working with RPM repositories, how do I resolve the "Error occurred while promoting queue items" error?
When working with RPM repositories in Artifactory, users may encounter the following error message:
2023-04-30T10:58:51.353Z [jfrt ] [WARN ] [4cdfc151e4820bff] [o.a.w.WorkQueueImpl:194 ] [bff|art-exec-3960976] - Error occurred while promoting queue items: There can be only one process running work for org.artifactory.addon.yum.virtual.index.RpmCalculationWorkItem@29e93d35
CauseThis error message indicates that the RPM metadata workers are currently overloaded. This situation can occur when there is a high workload but not enough resources available to deal with the threads.
SolutionThe number of workers available to take threads from the queue can be increased by modifying the corresponding system property in the artifactory.system.properties file. The file can be found at:
$JFROG_HOME/artifactory/var/etc/artifactory/artifactory.system.properties
There are two properties that control the number of workers available for RPM metadata calculations. These are:
- artifactory.rpm.metadata.calculation.workers
- artifactory.yum.virtual.metadata.calculation.workers
The default values for these properties are 8 and 5, respectively, for local and virtual repositories.
To resolve the issue, it is recommended to double the values of both properties. This can be done by editing the configuration file and changing the values as follows:
- artifactory.rpm.metadata.calculation.workers=16
- artifactory.yum.virtual.metadata.calculation.workers=10
After making these changes, restart the Artifactory server to ensure that the new values are loaded. Once the server has been restarted, it is recommended to reindex the affected repositories.
More Information:
For more information on how RPM repository indexing works in Artifactory, please refer to the following article:
https://jfrog.com/knowledge-base/how-rpm-repository-indexing-works-in-artifactory/